Jump to content

Custom Search



Welcome to Ford Transit Forum


Sign In  Log in with Facebook

Create Account
Welcome to Ford Transit Forum - home of the official Ford Transit Club. Like most online communities, you must register to create a topic or post in our community, but don't worry this is a simple free process that requires minimal information for you to signup. Be apart of Ford Transit Forum by signing in or creating an account.
  • Start new topics and reply to others
  • Subscribe to topics and forums to get email updates
  • Get your own profile page and make new friends
  • Send personal messages to other members
  • Create a photo album and post photos. . .more.
Posted Image
 
Guest Message by DevFuse

Photo
* * * * * 1 votes

ford transit 03 90bhp

gearbox 90bhp 135bhp 6speed 5 speed

  • Please log in to reply
1 reply to this topic

#1 OFFLINE   cleggy

cleggy

    New Member

  • Members
  • Pip
  • 1 posts
  • Region:European Union
  • Locationengland
  • Current Vehicle:ford transit

Posted 28 June 2014 - 05:53 PM

Hi I'm a Newby to this site asking for help I own a ford transit 03 90bhp 5 speed rwd van and the clutch went a few days ago. So me being me thought of a great idea to put a 6 speed gearbox in as I've always moaned about it going to slow and high revs when doing 60 mph feels like I'm killing the engine screaming at me so any way I got a 6 speed gearbox from a 06 transit rwd 135bhp . I brought a new the clutch for the 135bhp gearbox and went in ok had to buy a second hand propshaft . thinking all was good came to start it up started then stopped tried again same happened after a long think and many times trying no joy

so I thought it might be the crankshaft sensor new one brought still no joy

So thinking really hard it could only be one thing the new flywheel so here we go again taking the gearbox off again put the old fly wheel on and tried it with out gear box on it started and revs good so I re groved the clutch plate to try and see if it worked with the gearbox on

Now its up and running but I think that the thrust bearing is on the pressure plate all the time and clutch is slipping like hell I'm not sure this is the case I just need to advise as I could go and buy a 90bhp clutch and put it on I have a feeling it might do it again if I did

But when I had the 135bhp clutch in it didn't slip cos I tried it in gear to see

I was thinking about welding the flywheel to something like the old one as the old flywheel has about an inch of solid flywheel for crank sensor and the new one is groved out why I don't know but thought about filling it in and grinding it smooth answers would be great on this as I'm stumped now and not sure what to do I would really like the 6 speed box in









Lose this advertisement by becoming a member. Click here to create a free account.

#2 OFFLINE   Carguy1981

Carguy1981

    New Member

  • Members
  • Pip
  • 77 posts

Posted 20 July 2014 - 08:50 PM

I would also love the 6 speed but have no idea what to do






0 user(s) are reading this topic

0 members, 0 guests, 0 anonymous users

Privacy Policy Terms of Service ·